Required Zoom Update – Monday, August 16, 2021

Zoom logoOn Monday, August 16, all users (including non-Clemson users) joining a Clemson Zoom meeting will be required to have a minimum Zoom client version of 5.7.4 (available now). If you’re using an older version on Monday, you will be prompted to update before you can join a meeting.

You can update to the latest version now and avoid any interruption. Instructions for updating are available on the Zoom website.

 

 System Status

View Status Page

Skip Twitter Feed
 Follow @ClemsonIT

Happy first day of classes, Clemson students! Planning on printing? We've got a brand new video to walk you through it! youtu.be/j3k…

Skip to Twitter Feed Start Skip Instagram Feed Skip to Instagram Feed Start